Localization rendering issue — Admin (partial)

Incident Report for Zenoti

Update

The team is working on a fix and expected to rollout the changes in next few days. The impact is currently for few Admin UI elements as described earlier and all other application workflows are operating as expected. We will continue to post an update as we make progress for the impacted customers. Thank you for your patience.
Posted Jul 26, 2026 - 22:18 PDT

Identified

The issue has been identified and team is working on a fix. We will provide an update as soon as more information is available. Thank you for your patience.
Posted Jul 23, 2026 - 02:12 PDT

Investigating

We are facing issue with Localized content rendering in Zenoti application and some Admin UI elements may appear in English instead of the configured language. All other application workflows are operating as expected. Our team is actively investigating the issue and we will provide updates as soon as more information becomes available.
Posted Jul 22, 2026 - 03:06 PDT
This incident affects: Zenoti-AMRS02, Zenoti-AMRS03, Zenoti-AMRS04, Zenoti-AMRS05, Zenoti-AMRS09, Zenoti-AMRS11, Zenoti-AMRS12, Zenoti-AMRS13, Zenoti-AMRS14, Zenoti-AMRS21, Zenoti-AMRS22, Zenoti-CNDA01, Zenoti-CNDA03, Zenoti-EURO01, and Zenoti-EURO02.