Zenoti Application Slowness - AMRS11

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 10:37 PDT

Monitoring

The system has been stable and working fine since 9:40 a.m. PST and we are monitoring the results.
Posted Mar 14, 2026 - 10:22 PDT

Update

We are continuing to investigate the cause and will provide an update as soon as possible. Thank you for your patience.
Posted Mar 14, 2026 - 09:56 PDT

Investigating

We are observing a higher-than-normal response time on our monitoring systems for AMRS11, which may be causing the application to not respond or respond slowly. We are investigating the cause and will provide an update as soon as possible.
Posted Mar 14, 2026 - 09:22 PDT
This incident affected: Zenoti-AMRS11.