Thanksgiving Holiday Payout Schedule (United States)

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Nov 27, 2024 - 11:17 PST

Monitoring

Please note that there will be no payout deposits on Thursday, November 28th, 2024, in observance of Thanksgiving.

Payouts originally scheduled for this day will be deposited on Friday, November 29th, 2024.

Thank you for being so understanding, and we wish you a happy and safe Thanksgiving!
Posted Nov 25, 2024 - 09:24 PST
This incident affected: ZPay_US and Zpay (Stripe) _ US.