Issue with Analytics Reports

Incident Report for Zenoti

Resolved

The issue has been resolved and all the affected reports are now working fine since 1:40 PM PST.
Posted Jul 31, 2025 - 15:31 PDT

Identified

We have identified an issue with some of the analytics reports for customers using AMRS18, AMRS19 and AMRS20. All the other core functions of the Zenoti application are working fine.

Our team is actively working on applying a fix. We will share the next update once the issue has been resolved.

Thanks for your patience.
Posted Jul 31, 2025 - 09:52 PDT
This incident affected: Zenoti-AMRS18, Zenoti-AMRS19, and Zenoti-AMRS20.