MyZen Outage due to upstream service provider

Incident Report for Zenoti

Resolved

The outage is resolved. All MyZen services are now fully functional- including card transactions, balance display, and activity history. Thanks for your patience and support.
Posted Jun 12, 2025 - 15:15 PDT

Monitoring

One of our banking partners was experiencing an infrastructure issue impacting myZen connectivity to the banking systems. As a result, users of myZen Tips may have experienced issues with balance display, card transactions, and transaction history display.

Our partners have made progress with unblocking the banking services, and most users should now experience full service. We will continue to monitor the situation.
Posted Jun 12, 2025 - 13:30 PDT

Investigating

We're observing evidence of upstream service provider errors causing system instability isolated to MyZen.

All the other Zenoti services are functioning as expected.
Posted Jun 12, 2025 - 13:00 PDT
This incident affected: MyZen.