Slowness in certain workflows on AMRS11

Incident Report for Zenoti

Resolved

The incident has been resolved. All systems are functioning normally and no further issues have been observed. Thank you for your patience.
Posted Jul 15, 2026 - 11:49 PDT

Monitoring

A fix has been implemented, and the application is now working as expected. We will continue to monitor performance closely and provide updates if needed.
Posted Jul 15, 2026 - 11:33 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 15, 2026 - 11:23 PDT

Investigating

We are observing intermittent slowness in some workflows for customers hosted on AMRS11. Our engineers are actively looking into this to identify and mitigate.
Posted Jul 15, 2026 - 11:20 PDT
This incident affected: Zenoti-AMRS11.