Issue with Purchase Order Listing page

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 21:11 PDT

Monitoring

The fix has been successfully rolled out across all regions. The Purchase Order Listing page is now functioning as expected. We apologize for the inconvenience and appreciate your patience.
Posted Sep 10, 2026 - 18:38 PDT

Update

A fix has been implemented and the rollout is currently underway in a phased manner across all affected regions. This is expected to be completed within the next few hours. We will provide a final update once the rollout is complete. Thank you for your patience.
Posted Sep 10, 2026 - 10:36 PDT

Identified

The issue has been identified, and our team has been actively working to resolve this and will provide updates as the situation develops.

We apologize for any inconvenience and appreciate your patience.
Posted Sep 10, 2026 - 02:32 PDT

Investigating

We are currently investigating an issue affecting "Purchase Order Listing" page for some customers. All other application functionality remains unaffected.
Posted Sep 10, 2026 - 00:16 PDT
This incident affected: Zenoti-ASIA01, Zenoti-ASIA02, Zenoti-ASIA03, Zenoti-ASIA12, Zenoti-ASIA22, Zenoti-EMEA02, Zenoti-EMEA03, Zenoti-EURO01, and Zenoti-MIDE01.