Slowness in certain workflows on AMRS05

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 09:40 PDT

Monitoring

The slowness is resolved now. We're continuing to monitor the situation.
Posted Apr 01, 2026 - 08:22 PDT

Investigating

We are observing intermittent slowness in some workflows for the customers hosted on AMRS05. Our engineers are actively looking into this to identify and mitigate.
Posted Apr 01, 2026 - 07:36 PDT
This incident affected: Zenoti-AMRS05.