Issue with Payment Terminal Transactions

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 08:16 PDT

Monitoring

Our partner has confirmed that the issue is resolved, and the transactions are returning to normal. We are continuing to monitor the systems.
Posted Aug 21, 2025 - 07:52 PDT

Investigating

Zenoti customers in the US and Canada region might face issues with card transactions on terminal. The problem is due to a partner systems facing issue. Our engineering teams are actively working to with the partner to resolve it. We will keep you posted on the progress.

The manual and card-on-file charges are working fine. As an alternative, we request you to use that option in the interim.

All the other core functionalities of Zenoti are working fine.
Posted Aug 21, 2025 - 07:40 PDT
This incident affected: Zenoti-AMRS01, Zenoti-AMRS02, Zenoti-AMRS03, Zenoti-AMRS04, Zenoti-AMRS05, Zenoti-AMRS06, Zenoti-AMRS07, Zenoti-AMRS08, Zenoti-AMRS09, Zenoti-AMRS10, Zenoti-AMRS11, Zenoti-AMRS12, Zenoti-AMRS13, Zenoti-AMRS14, Zenoti-AMRS15, Zenoti-AMRS17, Zenoti-AMRS18, Zenoti-AMRS19, Zenoti-AMRS20, Zenoti-AMRS21, Zenoti-AMRS22, Zenoti-CNDA01, Zenoti-CNDA03, ZPay_US, and ZPay_CA.