Zenoti Application Outage -ASIA12

Incident Report for Zenoti

Resolved

All services have been fully restored. Core reports and analytics are now displaying the latest data, and response times are back to normal.
We appreciate your patience throughout this recovery. If you notice any lingering issues, please reach out to our support team.
Posted Mar 22, 2026 - 23:12 PDT

Update

Core reports are now showing the latest data. Analytics dashboards may still display stale data as the recovery process continues.
Our team is working to restore full data freshness across all analytics. We'll provide another update once analytics are fully up to date.
Thank you for your continued patience.
Posted Mar 22, 2026 - 04:43 PDT

Monitoring

Primary services have been restored and are operational. Users may experience slower than usual response times as full recovery is underway. Additionally, some reports and analytics may display stale data until the recovery process is complete.

Our team is actively working to bring all systems to full capacity. We'll provide another update once everything is fully restored.
Thank you for your patience.
Posted Mar 21, 2026 - 00:47 PDT

Update

We are continuing to investigate this issue.
Posted Mar 20, 2026 - 22:10 PDT

Update

We are continuing to investigate this issue.
Posted Mar 20, 2026 - 21:31 PDT

Investigating

We are observing a higher-than-normal response time on our monitoring systems for Zenoti-ASIA12, which may be causing the application to not respond or respond slowly. We are investigating the cause and will provide an update as soon as possible.
Posted Mar 20, 2026 - 20:21 PDT
This incident affected: Zenoti-ASIA12.