Facing intermittent errors

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 01:57 PST

Investigating

We are facing intermittent errors spike on EURO01. Customers hosted on this POD might see some issues intermittently. Our team is looking into the issue.
Posted Mar 05, 2026 - 01:40 PST
This incident affected: Zenoti-EURO01.