Intermittent issues in Zenoti Application

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Mar 22, 2026 - 18:37 PDT

Monitoring

We have deployed a fix to the issue and the application is working now. Our team is monitoring the situation closely.
Posted Mar 22, 2026 - 16:34 PDT

Update

We are continuing to investigate this issue.
Posted Mar 22, 2026 - 15:34 PDT

Investigating

We are seeing intermittent issues for customers hosted on Zenoti-AMRS02, Zenoti-AMRS09 and Zenoti-AMRS14. Our team is actively investigating the issue, and we will provide updates as soon as more information becomes available.
Posted Mar 22, 2026 - 14:30 PDT
This incident affected: Zenoti-ASIA01, Zenoti-AMRS02, Zenoti-AMRS09, and Zenoti-AMRS14.