This incident has been resolved. All the Core and Analytics reports are reflecting latest data.
Posted Mar 23, 2026 - 10:04 PDT
Update
Replication latency has been resolved, with data replication now fully operational. However, a specific table issue persists, which may cause temporary discrepancies in Core and Analytics reports. Our team has identified the root cause and is actively implementing a fix, with resolution expected within 24 hours; we will provide updates as more information becomes available. All other services are operating normally. Thank you for your patience.
Posted Mar 22, 2026 - 04:38 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2026 - 10:57 PDT
Investigating
We are currently experiencing a latency in the data replication for our Core and Analytics reports. This is delaying the update of the data in the reports for the customers hosted on AMRS13. All other application workflows are operating as expected.
Our team is actively investigating the issue, and we will provide updates as soon as more information becomes available.