Issue with Guest Search on EMEA02

Incident Report for Zenoti

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 06:56 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 21, 2026 - 06:25 PDT

Investigating

We are receiving reports of guest search not working in some cases for the customers hosted on EMEA02. Our team is actively working on identifying the issue and sort it ASAP.

Other functions of the application are working fine at this point.
Posted Apr 21, 2026 - 06:11 PDT
This incident affected: Zenoti-EMEA02.